CocosDragonJS, CrystalCraze and CocosPlayer runtime error [FIX SEGNALATION]

CocosDragonJS, CrystalCraze and CocosPlayer runtime error [FIX SEGNALATION]
0.0 0


i don’t know why nobody posted about it but the projects cocosdragonjs and crystalcraze don’t work in anyway!
They raise an exception on Physics function while load the JS engine.
To fix this bug we must include
#include “js_bindings_chipmunk_registration.h”
and add
under the other addRegisterCallback.
Then CocosPlayer won’t work too .
In two days i am become crazy in order to make all this works :stuck_out_tongue:
Sorry for my bad english but i’m italian.
I hope this will be helpful to anyone and i hope this fix will include in the next version :stuck_out_tongue:
Bye =)
EDIT: with this doesn’t compile iOs solution because more file missing il build phase :~~/
My doubt is am i the first how compile this sources? Who made this samples source had tried to run?


I have the same problem, CocosDragonJS CANNOT run at all


Hi,Antonio Gallo

Could you run the cocos dragon on cocos2d-x 2.1.2.


i’ve tried with 2.1.2-hotfix when i post the problem.
I am able to run cocosdragonjs duplicate watermelon with me and modifing some files and replace JS Code.

The JS engine settings are wrong.

There isn’t this: sc->addRegisterCallback(jsb_register_chipmunk);

and the JS Engine fail to start because don’t find the classes related to chipmunk!