Cocos2dx and Artemis [Entity-Component]

Cocos2dx and Artemis [Entity-Component]
0.0 0


Hi everyone,

I am new to Cocos2dx, and I would like to use it with the C*+ port of Artemis .
Unfortunately, I can’t seem to get Cocos2dx know about artemis.
Because the c*+ port is not up-to-date, I created a project to be able to change some of the classes, and build the library (the .a file).

Now, I would like to add this library to any cocos2dx project. But it just doesn’t work, and I am running out of ideas…

Here is my configuration :
I am on Windows.
I do everything in Eclipse.
I use Cygwin for the special build command.

Here is my error, when I include one of the header file from Artemis :
“xxxx.h” no such file or directory.

Here is what I tried :
Add the path to artemis (containing cpp and header files) to the “Paths and Symbols / Includes” of the C++ settings.
=> Eclipse proposes me the name of the header files (so it knows about them), but the build still fails.
Add the library (libartemis.a) to the “Paths and Symbols / Libraries”
=> Fails
Add the artemis folder to the “Paths and Symbols / Library Paths”
=> Fails
Tried to get the Artemis project inside Eclipse (I use Codeblocks for the compilation of artemis) and reference it inside the cocos2dx project
=> Fails

I tried all the combinations… I have no idea why it does not work.

To conclude : How can I add a custom library inside a cocos2dx project ?

Thanks to everyone reading me.

Happy coding!


Hi again,

I have still no clue and the topic is going down fast :frowning: , anyone ?



Ok, so I finally found something!

To use my library, I just copy everything (.cpp and .h files) inside a sub folder of the Classes folder and include it in the file.
It’s not clean to do it that way but at least it works.

If you find something cleaner I’m all ears !