cocos2dx 2.2.2 android 4.2.2 error @@@ ABORTING: INVALID HEAP ADDRESS IN dlfree addr=0x5c5fe000


#1

I get an error message from the logcat :
error @@@ ABORTING: INVALID HEAP ADDRESS IN dlfree addr=0x5c5fe000
Fatal signal 11 (SIGSEGV) at 0xdeadbaad (code=1), thread 6079 (Thread-1995)

the backtrace is:


Build fingerprint: 'Coolpad/Coolpad5891/Coolpad5891:4.1.2/JZO54K/4.1.045.P1.131208.5891:user/release-keys’
pid: 24876, tid: 24952, name: Thread-1437 >>> com.sanguo.game <<<
signal 11 (SIGSEGV), code 1 (SEGV_MAPERR), fault addr deadbaad
r0 00000043 r1 5ecf19a0 r2 00000003 r3 deadbaad
r4 401ada6c r5 5c5ffff8 r6 5ecf19c8 r7 401970e3
r8 5c600000 r9 00000000 sl 401a63ac fp 0000000c
ip 00000000 sp 5ecf19c8 lr 40185315 pc 40170a78 cpsr 00000030
d0 766f206874676e65 d1 0000000800000372
d2 0000005000000066 d3 586355180000006c
d4 0000000000000000 d5 0000000000000000
d6 43f0000043ca8000 d7 43870000c3870000
d8 0000000000000000 d9 0000000000000000
d10 0000000000000000 d11 0000000000000000
d12 0000000000000000 d13 0000000000000000
d14 0000000000000000 d15 0000000000000000
d16 0000000000000000 d17 0000000000000000
d18 3f800000410edab5 d19 070107010070079c
d20 0000000000001c07 d21 0000043f00890000
d22 0000000000080008 d23 0000000000000008
d24 3f56c16c16c76a94 d25 3f81111111185da8
d26 3fa555555555551c d27 3fc55555555554db
d28 3ff0000000000000 d29 0000000000000001
d30 fff0000000000000 d31 0000000000000018
scr 60000010

backtrace:
#00 pc 00013a78 /system/lib/libc.so
#01 pc 00015e55 /system/lib/libc.so (dlfree+1628)
#02 pc 00017003 /system/lib/libc.so (free+10)
#03 pc 0029dc2d /mnt/asec/com.sanguo.game-2/lib/libcocos2dlua.so (cocos2d::BitmapDC::~BitmapDC()+10)


#2

Well. You’re trying to access an invalid heap address. Somewhere you allocated memory in the heap, deleted or freed the object and then tried to access it again.

Object *obj = new Object();
obj->doSomething() <— is fine
delete obj;
obj->doSomething() <---- BAM! Error!!! … :frowning:

Try narrowing down the problem by setting breakpoints!


#3

but i just use lua ,never delete object


#4

I am facing the same problem.

my project works fine in iOS but crashing in android…

my error is

@@@ ABORTING: INVALID HEAP ADDRESS IN dlfree addr=0x5cf5b490
Fatal signal 11 (SIGSEGV) at 0xdeadbaad (code=1), thread 16777 (Thread-441)


#5

Hey friend,have you solved this problem in android?