cocos2d-x template doesn't show up in xcode 4.1.1

cocos2d-x template doesn't show up in xcode 4.1.1
0.0 0


Hi All,

My system:
Lion 10.7.1
xcode 4.1.1

I downloaded:

Ran sudo ./

All cocos2d-x template files were correctly installed under “xcode/Templates/cocos2d-x”.

I cannot see any cocos2d-x templates in xcode 4.1.1

Has anyone managed to get this working.



I traced the same bug report weeks ago, but didn’t reproduce it.
My suggestion is to try ./ uf, and select “4” to install xcode4 templates.


Thanks Walzer,

I tried running

./ uf, and select “4”

It copied all of the files over to the correct “xcode/Templates/cocos2d-x” directory. However, xcode 4.1.1 still doesn’t display the
templates. Perhaps its something about xcode 4.1.1 because it seems that other people are OK with xcode 4.1

If you have other ideas or should someone else on the forum come up with a solution, this would really be appreciated.




It is now working fine. Somehow the folders that were copied over did not have the correct permission on my machine.

Thanks again for your help.