cocos2d: CCZ: Failed to uncompress data

cocos2d: CCZ: Failed to uncompress data
0.0 0


Hi, I loaded a PVR file after exporting it with zwoptex and worked nice, now I added it compression to get a .pvr.ccz file and I’m getting a ‘cocos2d: CCZ: Failed to uncompress data’.

Worked ok on cocos2d-objective-c


Did you meet the problem on iOS?
If so, could you paste a demo to help us to reproduce it?


CCSprite::spriteWithFile(“map_default.pvr.ccz”); does not work but using “map_default.pvr” does. Obviously both files are added as resources to the project.

Here’s console log:

Cocos2d: cocos2d: GL_VENDOR: Apple Computer, Inc.
Cocos2d: cocos2d: GL_RENDERER: Apple Software Renderer
Cocos2d: cocos2d: GL_VERSION: OpenGL ES-CM 1.1 APPLE
Cocos2d: cocos2d: GL_MAX_TEXTURE_SIZE: 2048
Cocos2d: cocos2d: GL_MAX_MODELVIEW_STACK_DEPTH: 16
Cocos2d: cocos2d: GL supports PVRTC: YES
Cocos2d: cocos2d: GL supports BGRA8888 textures: NO
Cocos2d: cocos2d: GL supports NPOT textures: YES
Cocos2d: cocos2d: GL supports discard_framebuffer: YES
Cocos2d: cocos2d: compiled with NPOT support: NO
Cocos2d: cocos2d: compiled with VBO support in TextureAtlas : NO
Cocos2d: cocos2d: CCZ: Failed to uncompress data
Cocos2d: cocos2d: Couldn’t load PVR image /Users/luis/Library/Application Support/iPhone Simulator/4.3.2/Applications/159AC4E1-1AE0-4EA6-ABB6-75E3EDFF38D6/