I think that this is still not ideal.
These defines are still polluting default namespace. I think that the best way is to embed them into namespaces as well. By the way you can specify namespace in the body of method.
using namespace cocos2d;
return ccp(fooX, fooY);