CCHttpClient with SSL requests

CCHttpClient with SSL requests
0.0 0


Hi all,

I’m trying to send requests to an SSL page (a url of the form in my iOS app. Has any one been able to successfully do this? Nothing appears to be going through as is. I dug in to the code a bit and it looks like some of the SSL curl options aren’t being set inside HttpClient.cpp. I tried adding some, but it still doesn’t appear to be working. Is there an easy way to test if the curl.h I’m using is compiled with SSL functionality?


— Joel


Solved it by recompiling CURL with SSL enabled. I used the build scripts from here: Clone it and run ./build_curl --archs armv7,armv7s,i386 to compile curl. Drop the output in to the /cocos2dx/platform/third_party/ios/ folders and recompile. Make sure you use the ios-dev output if you need i386 (simulator) support. Bonus of upgrading to to curl 7.28.1 (from 7.26.0) as a result of this too.


Great solution! Sorry I know it’s an old post, but I’m working on this but found an issue, in Xcode 5 there is no llvm-gcc-4.2 an more, I used the ruby1.8 solution, so I had to change ‘llvm-gcc-4.2’ to ‘clang’ on the /lib/curl_builder/compiler.rb.
Now looking for a solution n Android…


Ummm, no sorry, using ‘clang’ gives me error when compiling for arm7 and arm7s, and only compiles for simulator, any ideas?