CCBReader not supporting recent version of CocosBuilder

CCBReader not supporting recent version of CocosBuilder
0.0 0


I downloaded cocos2d-2.0-rc0a-x-2.0 today, and I get an error when I try and load my test level I created a few weeks ago with CocosBuilder. CCBReader is expecting fileversion==2, and the version is 3. I am using CocosBuilder 1.1-beta2. What version of CocosBuilder is currently supported?


Load Cocos Builder 2.0


I am not sure which version of CocosBuilder I was using before, but I downloaded the current 2.0 beta1, created a new .ccb file, and I get the same error. (In fact, I was using a more recent version than 2.0beta1 before, from about 2 or 3 weeks ago, built from the source).

The version of CCBReader in Cocos2D-X 2.0rca does not supporting CocosBuilder 2.0 files.


I just checked my Cocos Builder 2.0 reader from github.

It has #define kCCBVersion 2

So I don’t know which version you use. Just download it with git from github and you are done

Rebuild your scenes of course.


I just downloaded the source, haven’t tried it yet, but if you look at “Documentation/4. CCB File”, you will see the line <td>fileVersion</td><td>Number</td><td>Must be 3</td>

Perhaps kCCBVersion is not the same as fileVersion. I will try building this version, but there is no Xcode project for some reason.


OK. I located the Xcode proj file and built the latest version of CocosBuilder. I have created another completely new CCB file, with a different name from the old one. I still get the fileVersion error. It does not work.


Do you get “WARNING! Incompatible ccbi file version ?”


No, I am not using CCBI, I am using CCB. The error is: “WARNING! Trying to load file made with a newer version of CocosBuilder, please update the CCBReader class”


You must publish a CCB file to CCBI ? Right. CCB is the scene file for Cocos Builder, not the one Cocos2d/-x loads. They need CCBI

I use CCBI (in Cocos2d () btw) and it works regarding file version.


OK, after figuring out how to publish, I have cleaned out all the old files, re-created a CocosBuilder project and published it…

I am loading like this:

@ CCNode *node = CCBReader::nodeGraphFromFile(“test3.ccbi”);@

This causes a EXC_BAD_ACCESS error, when trying to get the fileVersion from the dictionary. I don’t have a Cocos2D project to test with. Does Cocos2D-X CCBReader even support CCBI? I don’t see anything in the code to check the file type.


Right CCBI is not supported. Check :

Cocos2d-x supports only Cocos Builder 1.1 I guess


Steven Barnes:
You use old unofficial loader, which can load only .ccb (plist) files from CocosBuilder 1.1.

For loading new version from CocosBuilder 2.x you must use cococs2dx 2.0 (gles 2.0 branch) with official extension CCBReader, which read published .ccbi (binary) files.

But I have problems with version as well.
Its look like, that cocos2dx (cocos2d-2.0-rc2-x-2.0.1) support version 2, but CocosBuilder (2.0RC) publish to version 3.

Do you have changed CCBReader for ccbi version 3?

Thanks for sharing or help with resolving problem.


I’ve have already switched to the 2.0 gles branch, and that loads the CCBI files fine. Of course, there is now a newer version of CocosBuilder which I can’t use until CCBReader gets updated.


Steven Barnes

Can you please share old version of CocosBuilder?

Its not possible to download older version.




I’m not sure what you want. I am using the source branch v2 to build CocosBuilder (the version that works with cocos2d-x 2.0 and supports CCBI), I don’t have any version to give you.


I mean CocosBuilder build which you created from source branch v2.

So I don’t need to build own CocosBuilder.