cannot open file 'freetype.lib'

cannot open file 'freetype.lib'
0.0 0


I downloaded cocos2dx for windows phone 8 and I tried building the helloworld project in Visual Studio 2012 express for windows phone. But I keep getting this error.

error LNK1104: cannot open file 'freetype.lib'

I’m using cocos2dx-0.13.0-wp8-0.8, on windows 8 professional. Any help?

PS: It wont even run on the emulator.


Try search in this forum, there is a workable solution posted previously.


It turned out I didn’t have the right hardware to begin with. If it helps anyone, you need to be running a 64bit windows 8 with atleast 4 bg of ram. Also make sure your system supports hypervisor.(download ‘coreinfo.exe’ and check). Upgraded my system and now it works.


I download Cocos2d-x from and copy the missing 3 0r 4 missing files(included ‘freetype.lib’) to cocos2dx-0.13.0-wp8-0.8.
Problem solved.

I don’t know why cocos2dx-0.13.0-wp8-0.8 not include the ‘freetype.lib’ file. Maybe others can run it properly without this file.