Cannot build test.marmalade on Mac

Cannot build test.marmalade on Mac
0.0 0


Dear cocos2d-x developers and users!

I just transferred to Mac from Windows PC and I would like to work on projects that use cocos2d-x and marmalade. But building test.marmalade fails with the message that it cannot include “AvailabilityMacros.h” in ftconfig.h (the message: AvailabilityMacros.h: No such file or directory). My environment is: Mac OS X 10.6.8, Xcode 4.2, Marmalade 5.2. Which settings should I check? Any help will be appreciated.


We had this problem before, this is related to the free type library, I don’t have my Mac setup with Marmalade at the momement but will check this weekend.

I think the defines below need to be made for the MAC. The last email with Giovanni indicated that it should be in cocos2dx.mkf so I’m not sure for now.

if {{ defined APPLE }}

Put into cocos2dx.mkf, so that it should be visible to all subprojects.



Hi Oleg,

are you using cocos2d-1.0.1-x-0.12.0 release ?

The file freetype.mkf should have the defines indicated by Francis.



Thanks you very much for your replies and sorry for the late answer, but it didn’t work out.

I am actually using 0.12.0 release and have the defines in freetype.mkf (with APPLE instead of APPLE). I also tried to add them in cocos2dx.mkf. For some reason I still entered the same parts of code inside ftconfig.h. Ok, then I commented the line with AvailabilityMacros.h and tried to rebuild the project. And I obtained several errors - now in ftmac.c (with #include <CoreServices/CoreServices.h>#include <ApplicationServices/ApplicationServices.h>#include <sys/syslimits.h>). Ftmac.c is itself included in ftbase.c if DARWIN_NO_CARBON is not defined, so I commented it too, but it leaded to the linking error with reference to FT_New_Face from CCImage_marmalade.o. Tests for ios work fine. What should I check next?


Further investigations showed that building using ARM Debug/Release scheme worked well with project remained as is, the inclusion errors are only specific for x86 schemes.


I don’t own a mac, so I cannot try x86 build. But I know for sure that the x86 MAC version has a lot of limitations.
Please, check this one, perhaps it can be usefull: