Building works, but nothing happens

Building works, but nothing happens
0.0 0



I’m having a little bit of problem here. I’m trying to build and run cocos2d-win32 solution using VC exress 2008 (also tried 2010). I can successfully build the solution, but when I try to run HelloWorld example nothing happens. I mean I see no window and VC doesn’t catch any breakpoints altough program is clearly running. I can see it in task manager and also VC thinks it’s running. I’m using Win 7 64bit.


I’m not sure, but I can vaguely remember something about the GLES emulator not having (good) support for 64bit systems. Have you tried to (build and) run the sampe apps in 32bit mode? (if that’s an option for you).


I thought 0.99.5 was supposed to use OpenGL instead of ES in Windows?


Not yet, but it seems to be coming up in the next release. Check out the roadmap:


Try to update the driver of your video card. It may be helpful to resolve this problem.
So sorry that we haven’t finish the GLES -> GL featrue in 0.7.2. It will done in the near future.


I met the same problem yesterday.

At last, I found my screen color depth = 16BIT.

Change to 32BIT then it’s OK!


I experienced this same problem yesterday, and found the solution, which (at least in my case, and possibly many others) is related to my ATI video card & drivers.

My display depth was already 32-bit so Siyuan’s suggestion did not help.

I did some research into the Cocos OpenGL ES libs, which come from Khronos/PowerVR, and found this similar thread on their forum:

Coincidentally, I have an ATI Radeon 6850, using 10.12 drivers.
So I uninstalled my 10.12 drivers, and installed Catalyst 10.10 drivers — and my Cocos2d-X project now runs properly!

(okay, I hit a problem in HelloWorld, but Tests.exe runs perfectly for me).

According to Imagination/PowerVR:

Apologies for the slow reply.
This is an issue we have been looking into, and the fix will be in our 2.8 SDK release at the end of Feburary/start of March. We will be making an announcement on the forums and to the POWERVR Insider mailing list when it is available for download.

Hope this helps anyone else that’s experiencing this problem & using newer ATI drivers.


Another (far better) solution is to simply download the latest PowerVR SDK 2.8 from:

Just get the “Khronos OpenGL ES 1.1 SDKs” for “Windows 7/Vista/XP - OpenGL ES 1.1”.

Install it and then replace these files from cocos2d-x: libEGL.dll, libgles_cm.dll, libEGL.lib, libgles_cm.lib from:
k:2d-0.99.5-x-0.8.4\cocos2dx\platform\third_party\win32\librarieswith the new ones from:
c:Technologies\POWERVR SDK\OGLES_WINDOWS_X86EMULATION_2.08.28.0634\Builds\OGLES\WindowsX86\Lib
The headers of the SDK have not changed, so only those 4 binary files need to be updated.

Recompile cocos2d-x/your project and it will work perfectly.
Hope this helps someone with the same problem.


Thanks for your information. We can integrate the new version of PowerVR GLES lib in the next version