./build_native.sh not finding SimpleAudioEngine.h

./build_native.sh not finding SimpleAudioEngine.h
0.0 0


So I’ve been following the rules to the letter from here [http://www.jesusbosch.com/2012/06/how-to-set-up-android-and-win32-cocos2d.html] and my importing got stuck at compiling HelloWorldScene.cpp.

Compile++ thumb : hellocpp_shared <= HelloWorldScene.cpp jni/../..Classes/HelloWorldScene.cpp:2:31: fatal error: SimpleAudioEngine.h: No such file or directory compilation terminated

I’m building for Android 4.1
I’m using cygwin and my make version is make 3.81.
Everything is run with Administrator rights.
Also tried with Mingw and same result.


I think your Android.mk is wrong, you should refer to samples/HelloCpp/proj.android/jni/Android.mk.


Just compared them and they are identical… I even made all the files accessible [to my knowledge].


I think CocosDenshion static libraries are missing from HelloCpp android project, at least in latest version (cocos2d-2.0-x-2.0.4).

Try modifying the Android.mk to include cocosdenshion references:

LOCAL_WHOLE_STATIC_LIBRARIES := cocos2dx_static cocosdenshion_static


$(call import-module,cocos2dx) \
$(call import-module,CocosDenshion/android)



Did you solved your problem Alin Rizea?
I’ve got the same problem. I’m compiling my app on a Mac. Everything seems to work except third parties headers.