[BUG] The bug about CCSequence::actions(action1, action2)

[BUG] The bug about CCSequence::actions(action1, action2)
0.0 0


I’m creating an instance of CCSequence as follow:

CCAnimate animate = CCAnimate::actionWithDuration;
callFuncND = CCCallFuncND::actionWithTarget(this, callfuncND_selector(GameLayer::explosionFinished), newSprite);
CCRepeat repeatAction = CCRepeat::actionWithAction;
action = CCSequence::actions(repeatAction, callFuncND);

But there is an error occurred while the CCSequence::actions is called.

I debugging the code of CCSequence, then, I found the problem is the second argument always can’t get the duration.

The problem caused by this line in CCSequence::actions function :
pNow = va_arg(params, CCFiniteTimeAction**);
Variable pNow is not passed correctly, because the va_arg macro.
The alternately solution is to use the actionOneTwo or actionWithArray. The code likes this:
CCFiniteTimeAction**action = CCSequence::actionOneTwo(repeatAction, callFuncND);

Please fix this bug.


I managed to go around this bug by setting the way they do in the examples, passing a NULL as the last parameter. Must be the correct way of using actions(…, NULL) method (i think!).

Have you tried doing it ?



I tried actions(…, NULL) a moment ago. It works. It’s not a bug.