Black screen on start HelloWorld android eclipse on windows 7

Black screen on start HelloWorld android eclipse on windows 7
0.0 0


I have problem starting helloworld application on emulator and device.
When i run the program compile and emulator and device only showe black screen with gradient transition of white colour from left to right of the screen

i run:
windows 7
ndk r8
sdk 22.00

i changed api version on androidmanifet.xml, and when i set lower version, white gradient dissapear, but black screen

i removed images(helloworld.png…) from my project assets folder and nothing
i changed api virtual devices from 4.03 and 4.2.2 still nothing

my cocos2dxctivity had parameters
// Switch to supported OpenGL (ARGB888) mode on emulator
if (isAndroidEmulator())
this.mGLSurfaceView.setEGLConfigChooser(8 , 8, 8, 8, 16, 0);
here is my logcat
05-29 11:18:54.211: E/Trace(952): error opening trace file: No such file or directory (2)
05-29 11:18:54.263: D/dalvikvm(952): Trying to load lib /data/app-lib/org.cocos2dx.examlpe-1/ 0x40ce5cd8
05-29 11:18:54.352: D/dalvikvm(952): Added shared lib /data/app-lib/org.cocos2dx.examlpe-1/ 0x40ce5cd8
05-29 11:18:54.601: D/libEGL(952): loaded /system/lib/egl/
05-29 11:18:54.621: D/(952): HostConnection::get() New Host Connection established 0x2a15f6f8, tid 952
05-29 11:18:54.641: D/libEGL(952): loaded /system/lib/egl/
05-29 11:18:54.651: D/libEGL(952): loaded /system/lib/egl/
05-29 11:18:54.761: W/EGL_emulation(952): eglSurfaceAttrib not implemented
05-29 11:18:54.791: D/OpenGLRenderer(952): Enabling debug mode 0

any ideas

started.jpg (22.3 KB)


I just tried mac(mountain lion) android-eclipse with cocos2d-x, and the same thing happened.

I will try linux now, after that i don’t know what to do.


I skipped linux installation, and install android-eclipse cocos2d-x on different computer:
windows 7 32bit phenom 955bee,

the first one was windows 7 64bit with core i7-3770,

and again , black screen.

It must be my mistake in the process of making,
or it is the versions of the cocos2dx or sdk or ndk.

What do you recommend?


here is new logcat

05-31 09:19:34.912: E/Trace(1438): error opening trace file: No such file or directory (2)
05-31 09:19:34.982: D/dalvikvm(1438): Trying to load lib /data/app-lib/org.cocos2dx.examlpe-2/ 0x40ce4980
05-31 09:19:35.082: D/dalvikvm(1438): Added shared lib /data/app-lib/org.cocos2dx.examlpe-2/ 0x40ce4980
05-31 09:19:35.312: D/libEGL(1438): loaded /system/lib/egl/
05-31 09:19:35.332: D/(1438): HostConnection::get() New Host Connection established 0x2a183258, tid 1438
05-31 09:19:35.372: D/libEGL(1438): loaded /system/lib/egl/
05-31 09:19:35.382: D/libEGL(1438): loaded /system/lib/egl/
05-31 09:19:35.492: W/EGL_emulation(1438): eglSurfaceAttrib not implemented
05-31 09:19:35.532: D/OpenGLRenderer(1438): Enabling debug mode 0

I am using latest cocos2dx and ndk r8 and sdk 22.00
emulator is aPI 17, arm processor use gpu host, 3xxmb memory 800x480 resolution

this happend on windows 7 32bit,windows 7 64bit, and mac osx mountain lion.

It seems that eglsurfaceAttrib not implemented is error on all operating systems

Here is my .java file

package org.cocos2dx.examlpe;


import android.os.Bundle;

public class androidproba6 extends Activity{

protected void onCreate(Bundle savedInstanceState){

static {

Here is my androidmanifest.xml file

<?xml version="1.0" encoding="utf-8"?>


Same thing is happening with cocos2dx testcpp android sample


Finally find what was wrong.

I used old tutorials for setting up android with cocos2d-x, which told me to open file and change

import org.cocos2dx.lib.Cocos2dxActivity;

public class androidproba3 extends Cocos2dxActivity{
public class androidproba3 extends Activity{


you just need to go to project properties and go to java build path/source/link source
and add following folder

this is where Cocos2dxGLSurfaceView is

Well, hope someone will use this.