Black Screen In Release Mode

Black Screen In Release Mode
0.0 0


Hi everyone.
I am creating a windows rt game. I have a problem: when i run in debug mode, everything ’s ok. But when i run in release mode, after slash screen shown, i still heard sound and music (Game still running) but i get black screen! Everything works normally except the black screen!
Hope you guys have solution for this.
Thanks you!


Hey, Does anyone able to fix this problem? Please help me!


I am also facing the same problem. This never happened in cocos2dx 2.2 whether it is your release or debug. This issue has started appearing again for version 2.2.1. In this version they added visual studio 2013 project support for winrt. I faced the same issue when i used wp8 2.0 version. But i was able to fix it. I will surely inform you on this thread. If I am able to get a way around.


it is due to some project settings let me see


Follow these changes. This has been fixed in this pull request. Apply these changes or clone there git reposity. use master branch if you clone. It was just a typo


I am having a similar issue with the “simpleGame” project in the “cocos2d-winrt.vc2012” solution. when downloading cocos2dx version 2.2.1 from I tried fixing the typo in “cocos2dx/platform/winrt/CCPrecompiledShaders.cpp” but that did not seem to fix the isssue unfortunatly.

Any help/insight on this would be greatly appreciated :slight_smile: