App don't paint itslef and must be manually killed on windows 7 64 bits

App don't paint itslef and must be manually killed on windows 7 64 bits
0.0 0



I’ve downloaded cocos2d-x (versions 1.0.1-x-0.10.0, 1.0.1-x-0.11.0 and from git) and compiled it using visual studio 2010 professional edition.

When I run HelloWorld / test they don’t paint itself (no window shows up and I have to manually close/kill the process). visual studio doesn’t catch any breakpoints although program is clearly running.

After some research I found out this post:

I installed Khronos OpenGL ES 1.1 SDKs (Version 2.9, Release 1) and replaced the following files from cocos2d-x (cocos2dx\platform\third_party\win32\libraries:

  • libEGL.dll
  • libgles_cm.dll
  • libEGL.lib
  • libgles_cm.lib

with files provided by c:Technologies\POWERVR SDK\OGLES_WINDOWS_X86EMULATION_2.09.29.0649\Builds\OGLES\WindowsX86\Lib

After that when I run HelloWorld / test I got the following error

ERROR: Your Hardware is not capable to run OpenGL ES 1.1 emulation!

It seems bad news. I’m not sure if this error is caused because either my OS is 64 bits and PVR dlls are 32 bits or because my video card in not able to run OpenGL ES emulation.

Did anyone come across this error? Any solution other than install a new video card?

My environment:
Windows 7 Professional, 64-bit Service Pack 1 (Build 7601)
My display (on board): Intel 82945G Express Chipset Family (depth was already 32-bits and using the latest driver)