Android project crashing with Fatal signal 11 (SIGSEGV)

Android project crashing with Fatal signal 11 (SIGSEGV)
0.0 0


Hi all,

I’m in the process of setting up an Android project for an existing iOS-based game. I’ve got it all compiling properly (using, added to Eclipse, and copying to the device. However, when running the app I receive this error:

A/libc(7708): Fatal signal 11 (SIGSEGV) at 0x67110038 (code=2), thread 7773 (Thread-2270)

This is my first Android app, and I’m not even sure where to begin to resolve this issue. I can set breakpoints on the java code and that all seems to be running correctly, so I presume the error is coming from my C++ code. However, I’m not really sure where the problem is occurring and I can’t seem to debug/step around the code at all.

Could anybody provide any hints on how to debug something like this? Or at least point me in the direction of where the problem might be?

Thanks in advance for your help!


P.S. I’m running on a Nexus 7, and the HelloWorld and CocosTest examples both work on it fine…


You can use ndk-stack to print out the crash dump of you app.
Read the docs\NDK-STACK.html in your ndk directory for full step about using it.


Hi Splash Huang,

That sounds exactly like what I need. Thanks for helping out a newbie to Android, I really appreciate it.



How do you solve this problem? because I have the same problem, I tried differentes things and I couldn’t fix it.


I could solve this, With ndk-stack I could check the problem was the assets.


I got a similar problem. I’ve setup a multi platform (iOs/Android) project. The project runs fine in iOS, but crashes on my Android device with the same error. Logcat points that source of error is in libc. Perhaps the App is using too much memory? On iOS memory consumption in GameLayer is about 18M. Not too sure how to check this in Android/Eclipse.



As other guys said, you should use ndk-stack to print the stack information. You can refer to NDK_ROOT/documents for more information of how to use ndk-stack.