Android Build Issues - NDK r8b (Cannot find module with tag...)

Android Build Issues - NDK r8b (Cannot find module with tag...)
0.0 0


We have spent nearly a week of trying to get anything running on the Android environment with very little luck. We have tried on both the Mac & Windows 7 OS instances with limited success. We were able to get the “Hello World”

We are trying to get the Space Game tutorial up and running on Android with no luck. We seem to hit the same issue no matter how many times we have tried to run it and on several different machines. Below is a dump of the console from within Eclipse: (when attempting to build a sample app)

08:50:39 * Incremental Build of configuration Default for project test.t.t.test2dxTWO*
/Users//Code/Android/android-ndk-r8b/ndk-build all
Android NDK: Aborting. . Stop.
Android NDK: jni/ Cannot find module with tag ‘CocosDenshion/android’ in import path
Android NDK: Are you sure your NDK_MODULE_PATH variable is properly defined ?
Android NDK: The following directories were searched:
Android NDK:

08:50:39 Build Finished (took 124ms)

It clearly appears as though the NDK_MODULE_PATH is not being set correctly, but we cannot figure out how to get it to work appropriately. We have followed several tutorial write ups with no luck. Is there anyone who might able to help?

We have seen several posts where the NDK version matters, is that the case?

NOTE: We were able to get the Hello World application running on both iOS and Android.

MacOSX Lion 10.7.4
xCode 4.4.1
Android NDK r8b
Eclipse Juno


No need to let eclipse compile the code with ndk-build all, you can just run to compile the file and use eclipse to pack and install the compiled files.

If you really want to do compile this way, you can check NDK_MODULE_PATH which is set in the last part of


Check the project’s and see if it has correct paths in it.

If all else fails, re-unpack the Cocos2d-x root folder.