After compile, no effect on apk.


#1

Hi,

I create a game with cocos2d on iOS, then I export it to cocos2dx so it could work with Android. I already import it and it works. But when I make a modification to any cpp file (That’s already on Android.mk) And then I build it on Eclipse it launch the same apk. I try to erase the apt on the phone and clean the project on eclipse, but its still the same. I try to put a clog on app delegate and I can’t see it. I try to just kill the app with return 0 and no

It just load the first version I import to eclipse. I try to combine my project JAVA + C++ and compile both each time I run it and it compiles perfectly with build_native.sh but when it launches, it launches the same old version.

Any idea? This is getting me crazy :S

Thanks


#2

You must run again build_native.sh When you clean project you don’t delete obj folder and there all CPP object files are.


#3

Hi Dawin,
I always run build_native.sh but no effect, I delete the app from the device and re-biuld it and work


#4

Do you refresh your Eclipse project?


#5

I start a new project and works fine