Admob no show ad

Admob no show ad
0.0 0


I have trying to add the admob in the ios app.
Then, i using the following code

bannerView_ = [[GADBannerView alloc] initWithAdSize:kGADAdSizeBanner];
bannerView*.adUnitID = MY_BANNER_UNIT_ID;
bannerView*.rootViewController = self;
[self.view addSubview:bannerView_];
[bannerView_ loadRequest:[GADRequest request]];

and change the MY_BANNER_UNIT_ID to my banner ID.

I run the simulator, but the ad have not show.

What is the problem?
The app can’t to request the admob or the banner view have not add in the app?


Have you tried it on a real device?


Yes, i have try it in the ipad.


Well, does it work properly?


no, it is not work for simulator an ipad


Try this, I’m not sure if it will work.

bannerView_ = [[GADBannerView alloc] initWithAdSize:kGADAdSizeBanner];
bannerView_.adUnitID = MY_BANNER_UNIT_ID;
bannerView_.rootViewController = self;

// Instead of this, use the sharedApplication's keyWindow
//[self.view addSubview:bannerView_];

UIWindow * window = [ [ UIApplication sharedApplication ] keyWindow ];
UIViewController * tempVC = [ [ UIViewController alloc ] init ];
[ window addSubView:tempVC.view ];

[bannerView_ loadRequest:[GADRequest request]];


It is not work.
Btw, thanks you for you help.
i have change to use the iAd.
I just want to know what is the problem:(


I have same problem. I connected it with this tutorial:
App compiles but ads are not showing. Tested on iPadRetina and emulator.

2014-02-06 12:51:21.608 TestowaReklamy[2173:a0b]  To get test ads on this device, call: request.testDevices = @[ GAD_SIMULATOR_ID ];
2014-02-06 12:51:21.640 TestowaReklamy[2173:a0b] cocos2d: surface size: 960x640

	cocos2d.x.version: 2.2.1
	cocos2d.x.compiled_with_profiler: false
	cocos2d.x.compiled_with_gl_state_cache: true
	gl.vendor: Apple Computer, Inc.
	gl.renderer: Apple Software Renderer
	gl.version: OpenGL ES 2.0 APPLE-9.2.1
	gl.max_texture_size: 4096
	gl.max_texture_units: 8
	gl.max_samples_allowed: 4
	gl.supports_PVRTC: true
	gl.supports_NPOT: true
	gl.supports_BGRA8888: false
	gl.supports_discard_framebuffer: true
	gl.supports_vertex_array_object: true

So it seems to load properly…


Hi Guys,

I am getting same issue. I have implemented Admob ad in file. And also delegate

  • (void)adViewDidReceiveAd:(GADBannerView *)adView {
    NSLog(@“Received ad successfully”);

called properly.

But still I can’t see banner advertise.

Any one solved this ?
Then please help me. Your help will be appreciated.