3.0rc0 error when "cocos.py run -p android"

3.0rc0 error when "cocos.py run -p android"
0.0 0


F:\cocos2d-x-3.0rc0\tests\cpp-empty-test\proj.android>python F:\cocos2d-x-3.0rc0
\tools\cocos2d-console\bin/cocos.py run -p android
Runing command: compile
Can’t find config file .cocos-project.json in path F:\cocos2d-x-3.0rc0\tests\cpp



I think that, your ANT_ROOT is not good.


i’m getting the same error ( Can’t find config file .cocos-project.json ) with my 3.0RC0 project. my ANT_ROOT is defined.


ok, i fixed it. when i updated this project for 3.0RC0 (from an earlier version), i did not copy over the invisible “.cocos-project.json” file.

i simply made a new file named .cocos-project.json in the root of my project’s directory with the following contents:

{"project_type": "cpp"}

i have a question, though: why did the cocos2d-x developers decide to make this file an invisible dot-file? there are plenty of other config files that aren’t invisible. what is special about this one?


I have this same problem if i cat .cocos-project.json the file shows up with contents as the one bunnyhero made but compile keeps giving me
"Runing command: compile
Can’t find config file .cocos-project.json in path /Users/mo/Users/mo/Downloads/Android/cocos2d-x-3.1.1/~Desktop/Game2"
Do you know why the file cant be recognised,i understand that it is hidden but i expect it is runnable .Any help will be appreciated im a real beginer at this.


first:try ant -versionEnsure ant is right
second:ensure you have enter project directory
third:create a new project,copy .cocos-project.json to your project
fourth:try cocos run -p android
that is all i know ,best wishes to you